Tags/topics: 
1
Answers
Vote up!
0
Vote down!

Drupal 8 distribution and commerce compatibility

Hi guys!

I started building a site on the bais of Lightning distribution. I installed everything using composer. Trying to run "composer require "drupal/commerce 8.2.x-dev"" on this install throws composer compatibility issues.

How can this be resolved? I understand that both composer packages have different dependencies on the same modules. So, is it a problem of which one is being used? I would appreciate any help!

This is the error, that I get:
>>>
$ composer require "drupal/commerce 8.2.x-dev"
./composer.json has been updated
No patches supplied.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Can only install one of: drupal/inline_entity_form[8.1.x-dev, 8.1.0-alpha6].
- Can only install one of: drupal/inline_entity_form[8.1.x-dev, 8.1.0-alpha6].
- Can only install one of: drupal/inline_entity_form[8.1.x-dev, 8.1.0-alpha6].
- drupal/commerce 8.2.x-dev requires drupal/inline_entity_form 8.1.x-dev -> satisfiable by d rupal/inline_entity_form[8.1.x-dev].
- Installation request for drupal/commerce 8.2.x-dev -> satisfiable by drupal/commerce[8.2.x -dev].
- Installation request for drupal/inline_entity_form (locked at 8.1.0-alpha6) -> satisfiable by drupal/inline_entity_form[8.1.0-alpha6].

Installation failed, reverting ./composer.json to its original content.
>>>

Asked by: anrue
on July 19, 2016

1 Answer

Vote up!
0
Vote down!

I also opened an issue in the Lightning issue queue. One of the maintainers of Lightning offered to work with you guys together to increase compatibility.
https://www.drupal.org/node/2769231

Answer by: anrue
Posted: Jul 20, 2016
骚虎视频_骚虎app